aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWenHan Gu <Wenhan.gu@mediatek.com>2013-12-27 15:18:10 +0800
committerWenHan Gu <Wenhan.gu@mediatek.com>2013-12-27 15:23:40 +0800
commitd74e72004f57f6da2ecf7dbf1644c378c9bd5923 (patch)
tree8e6121444111992e1d50854919bd4656e33f8083 /configure.ac
parent32f1182873b975462ed8dcb3ed6bff230fbc0711 (diff)
downloadmclinker-d74e72004f57f6da2ecf7dbf1644c378c9bd5923.tar.gz
[Autoconf] Our bison syntax is only suitable for bison version < 3.0.
It will emit warning and break our buildbot since we use --enable-werror. Bison 2 Bison 3 ------------------------------------------ --------------------------------- %define namespace "mcld" %define api.namespace {mcld} %define "parser_class_name" "ScriptParser" %define parser_class_name {ScriptParser} ... ...
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7e463fb2..5ce266e2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -51,7 +51,8 @@ AC_PROG_CXX
AC_PATH_PROG([FLEX],[flex])
AX_PROG_FLEX_VERSION([2.5.35],[],[AC_MSG_ERROR([Require flex 2.5.35 or later])])
AC_PATH_PROG([BISON],[bison])
-AX_PROG_BISON_VERSION([2.4.3],[],[AC_MSG_ERROR([Require bison 2.4.3 or later])])
+AX_PROG_BISON_VERSION([2.4.3],[3.0],[],
+ [AC_MSG_ERROR([Require bison >= 2.4.3 and < 3.0])])
AC_LANG([C++])
LT_INIT