aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authordan sinclair <dj2@everburning.com>2019-03-28 13:45:01 -0400
committerGitHub <noreply@github.com>2019-03-28 13:45:01 -0400
commitd70c0e42f5723834ab03977c4e3c92185ecaf900 (patch)
tree247db266904ec1db51bd1b2de24b540f1ec37621 /src/CMakeLists.txt
parent6fa4f59b6fa6f6abe5aca5447f853c582e9b4750 (diff)
downloadamber-d70c0e42f5723834ab03977c4e3c92185ecaf900.tar.gz
Add destructors for the config objects. (#422)
This CL adds default destructors for the Vulkan and Dawn config objects. the EngineConfig object destructor is set to virtual. Issue #277.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index cad64da..cb60284 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -44,9 +44,11 @@ set(AMBER_SOURCES
if (${Vulkan_FOUND})
add_subdirectory(vulkan)
+ list(APPEND AMBER_SOURCES vulkan_engine_config.cc)
endif()
if (${Dawn_FOUND})
add_subdirectory(dawn)
+ list(APPEND AMBER_SOURCES dawn_engine_config.cc)
endif()
add_library(libamber ${AMBER_SOURCES})