summaryrefslogtreecommitdiff
path: root/dev-ros/laser_cb_detector/laser_cb_detector-0.10.13.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/laser_cb_detector/laser_cb_detector-0.10.13.ebuild')
-rw-r--r--dev-ros/laser_cb_detector/laser_cb_detector-0.10.13.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ros/laser_cb_detector/laser_cb_detector-0.10.13.ebuild b/dev-ros/laser_cb_detector/laser_cb_detector-0.10.13.ebuild
new file mode 100644
index 0000000000..6cecd2724c
--- /dev/null
+++ b/dev-ros/laser_cb_detector/laser_cb_detector-0.10.13.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/calibration"
+CATKIN_HAS_MESSAGES=yes
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Extracts checkerboard corners from a dense laser snapshot"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ dev-ros/actionlib[${PYTHON_USEDEP}]
+ dev-ros/cv_bridge
+ dev-ros/image_cb_detector
+ dev-ros/message_filters
+ dev-ros/roscpp
+ dev-ros/settlerlib
+"
+DEPEND="${RDEPEND}"