summaryrefslogtreecommitdiff
path: root/dev-ros/laser_cb_detector
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/laser_cb_detector')
-rw-r--r--dev-ros/laser_cb_detector/Manifest1
-rw-r--r--dev-ros/laser_cb_detector/laser_cb_detector-0.10.13.ebuild29
-rw-r--r--dev-ros/laser_cb_detector/laser_cb_detector-9999.ebuild29
-rw-r--r--dev-ros/laser_cb_detector/metadata.xml5
4 files changed, 64 insertions, 0 deletions
diff --git a/dev-ros/laser_cb_detector/Manifest b/dev-ros/laser_cb_detector/Manifest
new file mode 100644
index 0000000000..3890704895
--- /dev/null
+++ b/dev-ros/laser_cb_detector/Manifest
@@ -0,0 +1 @@
+DIST calibration-0.10.13.tar.gz 112305 SHA256 935755f9428e6b998d1a9ce10fcf11f3c119953ebe0b65eda855804ec8b8aea8 SHA512 95b5ea28428ea9726b6b1a8f24cd4c7cb84992e680761357c1a13dd92c362149a0a6104f6a44dbefad503db1a9c7a53135d9756b1ceea3a739b1baa14f9474eb WHIRLPOOL 94423d70268b053daee1da1b324582d2f8316c6feaa5c9291715b1861520cb2e67654daaa2156e8d15cd59ecb566bdd3cb76d42c7202b85680888bac3532002c
diff --git a/dev-ros/laser_cb_detector/laser_cb_detector-0.10.13.ebuild b/dev-ros/laser_cb_detector/laser_cb_detector-0.10.13.ebuild
new file mode 100644
index 0000000000..6cecd2724c
--- /dev/null
+++ b/dev-ros/laser_cb_detector/laser_cb_detector-0.10.13.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/calibration"
+CATKIN_HAS_MESSAGES=yes
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Extracts checkerboard corners from a dense laser snapshot"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ dev-ros/actionlib[${PYTHON_USEDEP}]
+ dev-ros/cv_bridge
+ dev-ros/image_cb_detector
+ dev-ros/message_filters
+ dev-ros/roscpp
+ dev-ros/settlerlib
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/laser_cb_detector/laser_cb_detector-9999.ebuild b/dev-ros/laser_cb_detector/laser_cb_detector-9999.ebuild
new file mode 100644
index 0000000000..6cecd2724c
--- /dev/null
+++ b/dev-ros/laser_cb_detector/laser_cb_detector-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/calibration"
+CATKIN_HAS_MESSAGES=yes
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Extracts checkerboard corners from a dense laser snapshot"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ dev-ros/actionlib[${PYTHON_USEDEP}]
+ dev-ros/cv_bridge
+ dev-ros/image_cb_detector
+ dev-ros/message_filters
+ dev-ros/roscpp
+ dev-ros/settlerlib
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/laser_cb_detector/metadata.xml b/dev-ros/laser_cb_detector/metadata.xml
new file mode 100644
index 0000000000..c42ea5b15c
--- /dev/null
+++ b/dev-ros/laser_cb_detector/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>