summaryrefslogtreecommitdiff
path: root/media-libs/phat/phat-0.4.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/phat/phat-0.4.1-r1.ebuild')
-rw-r--r--media-libs/phat/phat-0.4.1-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-libs/phat/phat-0.4.1-r1.ebuild b/media-libs/phat/phat-0.4.1-r1.ebuild
new file mode 100644
index 0000000000..cabb3f35a4
--- /dev/null
+++ b/media-libs/phat/phat-0.4.1-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools eutils
+
+DESCRIPTION="PHAT is a collection of GTK+ widgets geared toward pro-audio apps"
+HOMEPAGE="https://sourceforge.net/projects/phat.berlios/"
+SRC_URI="mirror://sourceforge/phat.berlios/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="debug"
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/libX11
+ gnome-base/libgnomecanvas"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ dev-util/gtk-doc"
+
+PATCHES=(
+ "${FILESDIR}/${P}-underlinking.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}