summaryrefslogtreecommitdiff
path: root/media-libs
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/imlib2/imlib2-1.4.7.ebuild2
-rw-r--r--media-libs/libepoxy/libepoxy-1.3.1.ebuild2
-rw-r--r--media-libs/libepoxy/libepoxy-9999.ebuild2
-rw-r--r--media-libs/phat/files/phat-0.4.1-underlinking.patch27
-rw-r--r--media-libs/phat/phat-0.4.1-r1.ebuild43
-rw-r--r--media-libs/rubberband/rubberband-1.8.1-r1.ebuild2
-rw-r--r--media-libs/x265/x265-1.8-r3.ebuild2
7 files changed, 75 insertions, 5 deletions
diff --git a/media-libs/imlib2/imlib2-1.4.7.ebuild b/media-libs/imlib2/imlib2-1.4.7.ebuild
index 4c5ad619e4..622f618fe7 100644
--- a/media-libs/imlib2/imlib2-1.4.7.ebuild
+++ b/media-libs/imlib2/imlib2-1.4.7.ebuild
@@ -16,7 +16,7 @@ inherit enlightenment toolchain-funcs multilib-minimal eutils
DESCRIPTION="Version 2 of an advanced replacement library for libraries like libXpm"
HOMEPAGE="https://www.enlightenment.org/"
-KEYWORDS="alpha amd64 ~arm hppa ~ia64 ~mips ~ppc ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+KEYWORDS="alpha amd64 arm hppa ~ia64 ~mips ~ppc ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
IUSE="bzip2 gif jpeg cpu_flags_x86_mmx mp3 png static-libs tiff X zlib"
diff --git a/media-libs/libepoxy/libepoxy-1.3.1.ebuild b/media-libs/libepoxy/libepoxy-1.3.1.ebuild
index 401e85d4ee..3cae16cbbc 100644
--- a/media-libs/libepoxy/libepoxy-1.3.1.ebuild
+++ b/media-libs/libepoxy/libepoxy-1.3.1.ebuild
@@ -12,7 +12,7 @@ if [[ ${PV} = 9999* ]]; then
GIT_ECLASS="git-r3"
fi
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
PYTHON_REQ_USE='xml(+)'
inherit autotools-multilib ${GIT_ECLASS} python-any-r1
diff --git a/media-libs/libepoxy/libepoxy-9999.ebuild b/media-libs/libepoxy/libepoxy-9999.ebuild
index 0dfcf8ccfc..98ef5b031c 100644
--- a/media-libs/libepoxy/libepoxy-9999.ebuild
+++ b/media-libs/libepoxy/libepoxy-9999.ebuild
@@ -12,7 +12,7 @@ if [[ ${PV} = 9999* ]]; then
GIT_ECLASS="git-r3"
fi
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
PYTHON_REQ_USE='xml(+)'
inherit autotools-multilib ${GIT_ECLASS} python-any-r1
diff --git a/media-libs/phat/files/phat-0.4.1-underlinking.patch b/media-libs/phat/files/phat-0.4.1-underlinking.patch
new file mode 100644
index 0000000000..d841cd0746
--- /dev/null
+++ b/media-libs/phat/files/phat-0.4.1-underlinking.patch
@@ -0,0 +1,27 @@
+- Remove hardcoded CFLAGS and -Werror flags
+- Fix underlinking caused by missing x11 dependency:
+* ../phat/.libs/libphat.so: error: undefined reference to 'XWarpPointer'
+
+--- phat-0.4.1/configure.ac
++++ phat-0.4.1/configure.ac
+@@ -17,7 +17,6 @@
+ [if test x$enable_debug = xyes; then with_debug=yes ; fi])
+
+ if test x$with_debug = xno; then
+- CFLAGS="-O3"
+ AC_DEFINE(DEBUG, 0, [[whether to display debugging output or not]])
+ else
+ AC_DEFINE(DEBUG, 1, [[whether to display debugging output or not]])
+@@ -46,10 +45,10 @@
+ GTK_DOC_CHECK(1.0)
+
+ # misc checks
+-PKG_CHECK_MODULES(MISC, libgnomecanvas-2.0)
++PKG_CHECK_MODULES(MISC, libgnomecanvas-2.0 x11)
+
+ # set compilation flags
+-CFLAGS="$CFLAGS $GTK_CFLAGS $MISC_CFLAGS -Wall -Werror"
++CFLAGS="$CFLAGS $GTK_CFLAGS $MISC_CFLAGS -Wall"
+ LIBS="$LIBS $GTK_LIBS $MISC_LIBS"
+
+ # print build summary
diff --git a/media-libs/phat/phat-0.4.1-r1.ebuild b/media-libs/phat/phat-0.4.1-r1.ebuild
new file mode 100644
index 0000000000..cabb3f35a4
--- /dev/null
+++ b/media-libs/phat/phat-0.4.1-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools eutils
+
+DESCRIPTION="PHAT is a collection of GTK+ widgets geared toward pro-audio apps"
+HOMEPAGE="https://sourceforge.net/projects/phat.berlios/"
+SRC_URI="mirror://sourceforge/phat.berlios/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="debug"
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/libX11
+ gnome-base/libgnomecanvas"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ dev-util/gtk-doc"
+
+PATCHES=(
+ "${FILESDIR}/${P}-underlinking.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
diff --git a/media-libs/rubberband/rubberband-1.8.1-r1.ebuild b/media-libs/rubberband/rubberband-1.8.1-r1.ebuild
index 93089232d5..1ad0356017 100644
--- a/media-libs/rubberband/rubberband-1.8.1-r1.ebuild
+++ b/media-libs/rubberband/rubberband-1.8.1-r1.ebuild
@@ -11,7 +11,7 @@ SRC_URI="http://code.breakfastquay.com/attachments/download/34/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha amd64 ~hppa ~ppc ~ppc64 ~x86"
+KEYWORDS="alpha amd64 ~hppa ~ppc ~ppc64 ~x86"
IUSE="static-libs"
RDEPEND="media-libs/vamp-plugin-sdk[${MULTILIB_USEDEP}]
diff --git a/media-libs/x265/x265-1.8-r3.ebuild b/media-libs/x265/x265-1.8-r3.ebuild
index 01d3a7c72d..63563ad7b6 100644
--- a/media-libs/x265/x265-1.8-r3.ebuild
+++ b/media-libs/x265/x265-1.8-r3.ebuild
@@ -13,7 +13,7 @@ else
SRC_URI="
https://bitbucket.org/multicoreware/x265/downloads/${PN}_${PV}.tar.gz
http://ftp.videolan.org/pub/videolan/x265/${PN}_${PV}.tar.gz"
- KEYWORDS="amd64 ~arm hppa ~ppc ppc64 x86"
+ KEYWORDS="amd64 arm hppa ~ppc ppc64 x86"
fi
DESCRIPTION="Library for encoding video streams into the H.265/HEVC format"