aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDerek Foreman <derek.foreman@collabora.com>2024-02-09 11:05:36 -0600
committerMarge Bot <emma+marge@anholt.net>2024-02-28 11:01:31 +0000
commiteb1235f3439a279bb188454fb9a762ec2ed2ae6e (patch)
tree31e45cdf4420ed9fe5ebadc47d140e619f778c75 /meson.build
parent4e219a22e2f6014cd552f8e88633b6587079c47a (diff)
downloadmesa3d-eb1235f3439a279bb188454fb9a762ec2ed2ae6e.tar.gz
loader/wayland: Add named queue fallback
If libwayland isn't new enough to create event queues with names, just throw away the name. It's just a debug feature anyway. Signed-off-by: Derek Foreman <derek.foreman@collabora.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/27824>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index c551bad452e..9471276131c 100644
--- a/meson.build
+++ b/meson.build
@@ -2020,6 +2020,12 @@ if with_platform_wayland
dependencies: dep_wayland_client)
pre_args += ['-DHAVE_WL_DISPATCH_QUEUE_TIMEOUT']
endif
+ if cc.has_function(
+ 'wl_display_create_queue_with_name',
+ prefix : '#include <wayland-client.h>',
+ dependencies: dep_wayland_client)
+ pre_args += ['-DHAVE_WL_CREATE_QUEUE_WITH_NAME']
+ endif
endif
dep_x11 = null_dep