aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index c551bad452e..9471276131c 100644
--- a/meson.build
+++ b/meson.build
@@ -2020,6 +2020,12 @@ if with_platform_wayland
dependencies: dep_wayland_client)
pre_args += ['-DHAVE_WL_DISPATCH_QUEUE_TIMEOUT']
endif
+ if cc.has_function(
+ 'wl_display_create_queue_with_name',
+ prefix : '#include <wayland-client.h>',
+ dependencies: dep_wayland_client)
+ pre_args += ['-DHAVE_WL_CREATE_QUEUE_WITH_NAME']
+ endif
endif
dep_x11 = null_dep