summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnton Hansson <hansson@google.com>2019-01-14 07:29:53 -0800
committerandroid-build-merger <android-build-merger@google.com>2019-01-14 07:29:53 -0800
commitbee631af718889764084b2d9f511d849b500e4a8 (patch)
tree6d26a0cfe261eab06f909460307c3350bff20dbd
parent9d88fad54526d02c6abb01c63ef8cd8a71f8a578 (diff)
parentade6480abc5131cfaab7c8eeb06bc72b15d34678 (diff)
downloadOneTimeInitializer-bee631af718889764084b2d9f511d849b500e4a8.tar.gz
Merge "Move OneTimeInitializer to /product" am: 506fc0422e
am: ade6480abc Change-Id: Ie0935da7024a3c13de7fa16214bc0898351c3627
-rw-r--r--Android.bp1
-rw-r--r--CleanSpec.mk50
2 files changed, 51 insertions, 0 deletions
diff --git a/Android.bp b/Android.bp
index bb17699..0bc44e8 100644
--- a/Android.bp
+++ b/Android.bp
@@ -19,6 +19,7 @@ android_app {
srcs: ["src/**/*.java"],
static_libs: ["android-common"],
sdk_version: "current",
+ product_specific: true,
privileged: true,
optimize: {
proguard_flags_files: ["proguard.flags"],
diff --git a/CleanSpec.mk b/CleanSpec.mk
new file mode 100644
index 0000000..37511f5
--- /dev/null
+++ b/CleanSpec.mk
@@ -0,0 +1,50 @@
+# Copyright (C) 2019 The Android Open Source Project
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+# If you don't need to do a full clean build but would like to touch
+# a file or delete some intermediate files, add a clean step to the end
+# of the list. These steps will only be run once, if they haven't been
+# run before.
+#
+# E.g.:
+# $(call add-clean-step, touch -c external/sqlite/sqlite3.h)
+# $(call add-clean-step, rm -rf $(PRODUCT_OUT)/obj/STATIC_LIBRARIES/libz_intermediates)
+#
+# Always use "touch -c" and "rm -f" or "rm -rf" to gracefully deal with
+# files that are missing or have been moved.
+#
+# Use $(PRODUCT_OUT) to get to the "out/target/product/blah/" directory.
+# Use $(OUT_DIR) to refer to the "out" directory.
+#
+# If you need to re-do something that's already mentioned, just copy
+# the command and add it to the bottom of the list. E.g., if a change
+# that you made last week required touching a file and a change you
+# made today requires touching the same file, just copy the old
+# touch step and add it to the end of the list.
+#
+# ************************************************
+# NEWER CLEAN STEPS MUST BE AT THE END OF THE LIST
+# ************************************************
+
+# For example:
+#$(call add-clean-step, rm -rf $(OUT_DIR)/target/common/obj/APPS/AndroidTests_intermediates)
+#$(call add-clean-step, rm -rf $(OUT_DIR)/target/common/obj/JAVA_LIBRARIES/core_intermediates)
+#$(call add-clean-step, find $(OUT_DIR) -type f -name "IGTalkSession*" -print0 | xargs -0 rm -f)
+#$(call add-clean-step, rm -rf $(PRODUCT_OUT)/data/*)
+$(call add-clean-step, rm -rf $(PRODUCT_OUT)/system/priv-app/OneTimeInitializer)
+
+# ************************************************
+# NEWER CLEAN STEPS MUST BE AT THE END OF THE LIST
+# ************************************************