summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHongyu Zhang <hongyu.zhang@intel.com>2012-04-01 09:10:12 +0800
committerXiaokang Qin <xiaokang.qin@intel.com>2012-08-31 09:47:11 +0800
commit89b07ea50cdb0bd9079590edc55013b5ff0efacd (patch)
tree604c6f9196206a7c9fb390071e1d95496d98a9c9
parentb4655f96bb0268e3d457cf32a58c0eeed8501880 (diff)
downloadPinyinIME-89b07ea50cdb0bd9079590edc55013b5ff0efacd.tar.gz
PinyinIME crashed in userdebug version
The root cause of this issue is nativeImOpenDecoder method is optimized by JAVA compiler in userdebug version. And JVM could not find this symbol in the virtual table of PinyinDecoderService class, and this will cause JNI library load fail. Solution is avoid this optimization. Change-Id: I095860c407877ca3b9184cc82fa5c0c0d71302c0 Author: Hongyu Zhang <hongyu.zhang@intel.com> Signed-off-by: Xiaokang Qin <xiaokang.qin@intel.com> Signed-off-by: Bruce Beare <bruce.j.beare@intel.com> Signed-off-by: Jack Ren <jack.ren@intel.com> Author-tracking-BZ: 22639
-rw-r--r--Android.mk3
-rw-r--r--proguard.flags3
2 files changed, 6 insertions, 0 deletions
diff --git a/Android.mk b/Android.mk
index d390749..6512720 100644
--- a/Android.mk
+++ b/Android.mk
@@ -22,6 +22,9 @@ LOCAL_PROGUARD_FLAG_FILES := proguard.cfg
# Make sure our dictionary file is not compressed, so we can read it with
# a raw file descriptor.
LOCAL_AAPT_FLAGS := -0 .dat
+LOCAL_AAPT_FLAGS += -0 .dict
+
+LOCAL_PROGUARD_FLAG_FILES := proguard.flags
include $(BUILD_PACKAGE)
diff --git a/proguard.flags b/proguard.flags
new file mode 100644
index 0000000..2888038
--- /dev/null
+++ b/proguard.flags
@@ -0,0 +1,3 @@
+-keep class com.android.inputmethod.pinyin.PinyinDecoderService {
+ *;
+}