summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean-Baptiste Queru <jbq@google.com>2012-05-04 09:19:26 -0700
committerAndroid Git Automerger <android-git-automerger@android.com>2012-05-04 09:19:26 -0700
commitb4655f96bb0268e3d457cf32a58c0eeed8501880 (patch)
tree3364f08962dd2307749f601698d4ca93e63bae5f
parent272bd8691dd6cd81d4651a61ee5ea7df8d6e5787 (diff)
parent5b566bc005d14fc083751c9079605a99779dcab2 (diff)
downloadPinyinIME-b4655f96bb0268e3d457cf32a58c0eeed8501880.tar.gz
am 5b566bc0: Merge "provent nativeImOpenDecoder from being removed by proguard"
* commit '5b566bc005d14fc083751c9079605a99779dcab2': provent nativeImOpenDecoder from being removed by proguard
-rw-r--r--Android.mk2
-rw-r--r--proguard.cfg3
2 files changed, 5 insertions, 0 deletions
diff --git a/Android.mk b/Android.mk
index b0741e0..d390749 100644
--- a/Android.mk
+++ b/Android.mk
@@ -17,6 +17,8 @@ LOCAL_STATIC_JAVA_LIBRARIES := com.android.inputmethod.pinyin.lib
LOCAL_CERTIFICATE := shared
+LOCAL_PROGUARD_FLAG_FILES := proguard.cfg
+
# Make sure our dictionary file is not compressed, so we can read it with
# a raw file descriptor.
LOCAL_AAPT_FLAGS := -0 .dat
diff --git a/proguard.cfg b/proguard.cfg
new file mode 100644
index 0000000..c7ef519
--- /dev/null
+++ b/proguard.cfg
@@ -0,0 +1,3 @@
+-keep class com.android.inputmethod.pinyin.PinyinDecoderService{
+ native static boolean nativeImOpenDecoder(byte[], byte[]);
+}