summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean-Baptiste Queru <jbq@google.com>2012-05-03 18:48:02 -0700
committerandroid code review <noreply-gerritcodereview@google.com>2012-05-03 18:48:03 -0700
commit5b566bc005d14fc083751c9079605a99779dcab2 (patch)
treeee6af082761f245d1f081e38629c5d30dde7e1d6
parente5520ea84671e907799217315ee3b47130d6e2ce (diff)
parent7ae6a22c025e3e4588faefe73824bf75e10c3e02 (diff)
downloadPinyinIME-5b566bc005d14fc083751c9079605a99779dcab2.tar.gz
Merge "provent nativeImOpenDecoder from being removed by proguard"android-sdk-adt_r20tools_r20ics-plus-aosp
-rw-r--r--Android.mk2
-rw-r--r--proguard.cfg3
2 files changed, 5 insertions, 0 deletions
diff --git a/Android.mk b/Android.mk
index b0741e0..d390749 100644
--- a/Android.mk
+++ b/Android.mk
@@ -17,6 +17,8 @@ LOCAL_STATIC_JAVA_LIBRARIES := com.android.inputmethod.pinyin.lib
LOCAL_CERTIFICATE := shared
+LOCAL_PROGUARD_FLAG_FILES := proguard.cfg
+
# Make sure our dictionary file is not compressed, so we can read it with
# a raw file descriptor.
LOCAL_AAPT_FLAGS := -0 .dat
diff --git a/proguard.cfg b/proguard.cfg
new file mode 100644
index 0000000..c7ef519
--- /dev/null
+++ b/proguard.cfg
@@ -0,0 +1,3 @@
+-keep class com.android.inputmethod.pinyin.PinyinDecoderService{
+ native static boolean nativeImOpenDecoder(byte[], byte[]);
+}