summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Android.mk2
-rw-r--r--proguard.cfg3
2 files changed, 5 insertions, 0 deletions
diff --git a/Android.mk b/Android.mk
index b0741e0..d390749 100644
--- a/Android.mk
+++ b/Android.mk
@@ -17,6 +17,8 @@ LOCAL_STATIC_JAVA_LIBRARIES := com.android.inputmethod.pinyin.lib
LOCAL_CERTIFICATE := shared
+LOCAL_PROGUARD_FLAG_FILES := proguard.cfg
+
# Make sure our dictionary file is not compressed, so we can read it with
# a raw file descriptor.
LOCAL_AAPT_FLAGS := -0 .dat
diff --git a/proguard.cfg b/proguard.cfg
new file mode 100644
index 0000000..c7ef519
--- /dev/null
+++ b/proguard.cfg
@@ -0,0 +1,3 @@
+-keep class com.android.inputmethod.pinyin.PinyinDecoderService{
+ native static boolean nativeImOpenDecoder(byte[], byte[]);
+}