summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWink Saville <wink@google.com>2012-07-11 18:06:30 -0700
committerWink Saville <wink@google.com>2012-07-11 18:06:30 -0700
commit582c67590f5c2814bd0b64381ef587fb966d3a9f (patch)
treed4022a6507143f08283e4a0e87ff9192ddb8575a
parentb79d1bfe2a9bfc19b632c443c57ad1106fb13e67 (diff)
parent917cf0fdd6d45ce901e63c54eb100920daeb89bf (diff)
downloadDrmProvider-582c67590f5c2814bd0b64381ef587fb966d3a9f.tar.gz
Merge commit '917cf0fd' into mit
* commit '917cf0fd': Use telephony-common
-rw-r--r--Android.mk2
-rw-r--r--src/com/android/providers/drm/DrmPushReceiver.java4
2 files changed, 3 insertions, 3 deletions
diff --git a/Android.mk b/Android.mk
index 6ee75f0..66989db 100644
--- a/Android.mk
+++ b/Android.mk
@@ -5,7 +5,7 @@ LOCAL_MODULE_TAGS := optional
LOCAL_SRC_FILES := $(call all-subdir-java-files)
-LOCAL_JAVA_LIBRARIES :=
+LOCAL_JAVA_LIBRARIES := telephony-common
LOCAL_PACKAGE_NAME := DrmProvider
LOCAL_CERTIFICATE := media
diff --git a/src/com/android/providers/drm/DrmPushReceiver.java b/src/com/android/providers/drm/DrmPushReceiver.java
index abe5ca0..4922330 100644
--- a/src/com/android/providers/drm/DrmPushReceiver.java
+++ b/src/com/android/providers/drm/DrmPushReceiver.java
@@ -22,11 +22,11 @@ import java.io.IOException;
import android.drm.mobile1.DrmException;
import android.drm.mobile1.DrmRights;
import android.drm.mobile1.DrmRightsManager;
-import static android.provider.Telephony.Sms.Intents.WAP_PUSH_RECEIVED_ACTION;
import android.content.Context;
import android.content.Intent;
import android.content.BroadcastReceiver;
+import android.provider.Telephony;
import android.util.Log;
public class DrmPushReceiver extends BroadcastReceiver {
@@ -34,7 +34,7 @@ public class DrmPushReceiver extends BroadcastReceiver {
@Override
public void onReceive(Context context, Intent intent) {
- if (intent.getAction().equals(WAP_PUSH_RECEIVED_ACTION)) {
+ if (intent.getAction().equals(Telephony.Sms.Intents.WAP_PUSH_RECEIVED_ACTION)) {
// Get right mimetype.
String rightMimeType = intent.getType();
if (DrmRightsManager.DRM_MIMETYPE_RIGHTS_XML_STRING.equals(rightMimeType) ||