aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJF Bastien <jfbastien@apple.com>2019-02-07 05:20:00 +0000
committerJF Bastien <jfbastien@apple.com>2019-02-07 05:20:00 +0000
commit33c30c0b0969655cbd76bcaf94f3f4403bd4d7f6 (patch)
tree4c835fad207558a4aea4ef0af7e65d3e72631851 /CMakeLists.txt
parent86ab198b4f425f77256e745d92d43abf59a5bc05 (diff)
downloadllvm-33c30c0b0969655cbd76bcaf94f3f4403bd4d7f6.tar.gz
Bump minimum toolchain version
Summary: The RFC on moving past C++11 got good traction: http://lists.llvm.org/pipermail/llvm-dev/2019-January/129452.html This patch therefore bumps the toolchain versions according to our policy: llvm.org/docs/DeveloperPolicy.html#toolchain Subscribers: mgorny, jkorous, dexonsmith, llvm-commits, mehdi_amini, jyknight, rsmith, chandlerc, smeenai, hans, reames, lattner, lhames, erichkeane Differential Revision: https://reviews.llvm.org/D57264 git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@353374 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 02938a3a659..5c1cddabc4f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -448,9 +448,12 @@ option(LLVM_ENABLE_EXPENSIVE_CHECKS "Enable expensive checks" OFF)
set(LLVM_ABI_BREAKING_CHECKS "WITH_ASSERTS" CACHE STRING
"Enable abi-breaking checks. Can be WITH_ASSERTS, FORCE_ON or FORCE_OFF.")
-option(LLVM_FORCE_USE_OLD_HOST_TOOLCHAIN
+option(LLVM_FORCE_USE_OLD_TOOLCHAIN
"Set to ON to force using an old, unsupported host toolchain." OFF)
+option(LLVM_TEMPORARILY_ALLOW_OLD_TOOLCHAIN
+ "Set to ON to only warn when using a toolchain which is about to be deprecated, instead of emitting an error." OFF)
+
option(LLVM_USE_INTEL_JITEVENTS
"Use Intel JIT API to inform Intel(R) VTune(TM) Amplifier XE 2011 about JIT code"
OFF)