aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorQuentin Colombet <qcolombet@apple.com>2017-01-26 23:53:31 +0000
committerQuentin Colombet <qcolombet@apple.com>2017-01-26 23:53:31 +0000
commit566dac54870d1eafa4331f17bdec5cd24d533015 (patch)
tree8f96c732af7c1ba036a81e840f3176a018355486 /CMakeLists.txt
parenteca8aa608d962e09ea9710670f1c412f608a6f12 (diff)
downloadllvm-566dac54870d1eafa4331f17bdec5cd24d533015.tar.gz
Switch the default for building GlobalISel.
Now, GlobalISel will be built by default. To turn that off, one has to use -DLLVM_BUILD_GLOBAL_ISEL=OFF on the cmake command line. <rdar://problem/30004433> git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@293232 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bd5faacf6c3..5cb24ea7d78 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -178,7 +178,7 @@ if(LLVM_DEPENDENCY_DEBUGGING)
endif()
endif()
-option(LLVM_BUILD_GLOBAL_ISEL "Experimental: Build GlobalISel" OFF)
+option(LLVM_BUILD_GLOBAL_ISEL "Experimental: Build GlobalISel" ON)
if(LLVM_BUILD_GLOBAL_ISEL)
add_definitions(-DLLVM_BUILD_GLOBAL_ISEL)
endif()