aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVassil Vassilev <v.g.vassilev@gmail.com>2017-06-09 22:09:57 +0000
committerVassil Vassilev <v.g.vassilev@gmail.com>2017-06-09 22:09:57 +0000
commit7bdba100fbdbbaee4d09da6e04155b0f2aa1288a (patch)
treef95720d103a36295fd1f86b57c4599418075ee09 /CMakeLists.txt
parentaf1531a5be220eed68bd63994409949990079eaa (diff)
downloadllvm-7bdba100fbdbbaee4d09da6e04155b0f2aa1288a.tar.gz
Enable c++1z experimental builds.
Patch by David Abdurachmanov! git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@305123 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1d9139a62c3..431785d3dd0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -385,6 +385,7 @@ else()
option(LLVM_ENABLE_LOCAL_SUBMODULE_VISIBILITY "Compile with -fmodules-local-submodule-visibility." ON)
endif()
option(LLVM_ENABLE_CXX1Y "Compile with C++1y enabled." OFF)
+option(LLVM_ENABLE_CXX1Z "Compile with C++1z enabled." OFF)
option(LLVM_ENABLE_LIBCXX "Use libc++ if available." OFF)
option(LLVM_ENABLE_LLD "Use lld as C and C++ linker." OFF)
option(LLVM_ENABLE_PEDANTIC "Compile with pedantic enabled." ON)