summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean-Baptiste Queru <jbq@google.com>2012-08-31 08:20:46 -0700
committerandroid code review <noreply-gerritcodereview@google.com>2012-08-31 08:20:46 -0700
commita08d08cdea4319fb74b55289e1b4e1b1a5249bc2 (patch)
tree604c6f9196206a7c9fb390071e1d95496d98a9c9
parentb4655f96bb0268e3d457cf32a58c0eeed8501880 (diff)
parent89b07ea50cdb0bd9079590edc55013b5ff0efacd (diff)
downloadPinyinIME-a08d08cdea4319fb74b55289e1b4e1b1a5249bc2.tar.gz
-rw-r--r--Android.mk3
-rw-r--r--proguard.flags3
2 files changed, 6 insertions, 0 deletions
diff --git a/Android.mk b/Android.mk
index d390749..6512720 100644
--- a/Android.mk
+++ b/Android.mk
@@ -22,6 +22,9 @@ LOCAL_PROGUARD_FLAG_FILES := proguard.cfg
# Make sure our dictionary file is not compressed, so we can read it with
# a raw file descriptor.
LOCAL_AAPT_FLAGS := -0 .dat
+LOCAL_AAPT_FLAGS += -0 .dict
+
+LOCAL_PROGUARD_FLAG_FILES := proguard.flags
include $(BUILD_PACKAGE)
diff --git a/proguard.flags b/proguard.flags
new file mode 100644
index 0000000..2888038
--- /dev/null
+++ b/proguard.flags
@@ -0,0 +1,3 @@
+-keep class com.android.inputmethod.pinyin.PinyinDecoderService {
+ *;
+}